ASNA Product Version Policy

This page provides our version policy for supported and many retired products. It shows, by product and version, what platforms are supported. If you need need version policy information for a retired product that isn’t listed on this page please send us an email at info@asna.com
Product legend: = Supported = Retired and not supported = Beta
Version legend: = Supported = Retired and not Supported = Beta = Support withdrawn
Supported ASNA products/versions receive periodic updates, fixes, and/or enhancements and are tested on the platforms listed. Use supported products on non-support platforms at your own risk.
Retired ASNA products/versions no longer receive periodic updates, fixes, and/or enhancements. They are also no longer tested on any platform. Note that a "retired" product may work on newer platforms than are listed for it. Use retired products on any platform at your own risk.
Upgrades for any products listed here are covered by an active maintenance plan.

Version policy notes

  • Windows 8.1 reached end-of-support from Microsoft on January 10th, and is no longer a supported ASNA platform.
  • SQL Server 2012 R2 and Windows Server 2012 R2 reach end-of-support on October 10, 2023. At that time ASNA will no longer support those versions.
  • Windows Home and mobile/tablet versions are not supported.
  • La compatibilidad con el sistema operativo de 64 bits es solo para la arquitectura X86-64. El procesador Itanium de 64 bits no es compatible.
  • Any platforms not listed on this page are not supported (ie, Windows Server 2008 R2).

Quick Navigation


DataGate para IBM i

The target GA availability is 2Q2023.

V6R1
V7R1
V7R2
V7R3
V7R4
V7R5 1
1 - Support pending in DataGate for IBM i 17.x coming 2Q2023.
V6R1
V7R1
V7R2 1
V7R3
V7R4
V7R5 2
1 - IBM ended V7R2 support on April 30, 2021.
2 - Support pending in DataGate for IBM i 17.x coming 2Q2023.
V6R1
V7R1
V7R2 1
V7R3
V7R4
V7R5 2
1 - IBM ended V7R2 support on April 30, 2021.
2 - Support pending in DataGate for IBM i 17.x coming 2Q2023.
V6R1
V7R1
V7R2
V7R3
V7R4
V7R5
V6R1
V7R1
V7R2
V7R3
V7R4
V7R5
V6R1
V7R1
V7R2
V7R3
V7R4
V7R5
V6R1
V7R1
V7R2
V7R3
V7R4
V7R5

DataGate for SQL Server (DSS)

The target GA availability is 2Q2023.

Win 8.1
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
Sql Srv 2014
Sql Srv 2016
Sql Srv 2017
Sql Srv 2019
Sql Srv 2022
Win 8.1 1
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
Sql Srv 2014
Sql Srv 2016
Sql Srv 2017
Sql Srv 2019
Sql Srv 2022 2
1 - Microsoft retired Windows 8.1 in Jan 2023.
2 - Support pending in DSS 17.x coming 2Q2023.
Win 8.1 1
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
Sql Srv 2014
Sql Srv 2016
Sql Srv 2017
Sql Srv 2019
Sql Srv 2022 2
1 - Microsoft retired Windows 8.1 in Jan 2023.
2 - Support pending in DSS 17.x coming 2Q2023.
Win 8.1 1
Win 10
Win 11
1 - Microsoft retired Windows 8.1 in Jan 2023.

DataGate para Windows y aplicaciones de escritorio

Win 8.1 1
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
1 - Microsoft retired Windows 8.1 in Jan 2023.
Win 8.1 1
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
1 - Microsoft retired Windows 8.1 in Jan 2023.

Visual RPG for .NET

Target GA availability is 2Q2023. These requirements also apply to Visual RPG for .NET Windows Deployment and the Upgrade Assistant.

Visual Studio VS 2022 1
Win 8.1 2
DataGate 16.x+ 3
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
1 - AVR 17.x requires a VS 2022 Pro edition and up.
2 - Microsoft retired Windows 8.1 in Jan 2023.
3 - AVR 16.x requires DataGate 16.x and up.

These requirements also apply to Visual RPG for .NET Windows Deployment and the Upgrade Assistant.

Visual Studio VS 2019 1
Win 8.1 2
DataGate 16.x+ 3
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
1 - AVR 16.x requires a VS 2019 Pro edition and up. VS 2019 Community Edition does not nork with AVR 16.x.
2 - Microsoft retired Windows 8.1 in Jan 2023.
3 - AVR 16.x requires DataGate 16.x and up.

These requirements also apply to Visual RPG for .NET Windows Deployment and the Upgrade Assistant.

Visual Studio VS 2017 1
Win 8.1 2
DataGate 15.x+ 3
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
1 - AVR 15.x requires VS 2017 Community Edition and up. This is the last year that the Community Edition works with AVR
2 - Microsoft retired Windows 8.1 in Jan 2023.
3 - AVR 15.x requires with DataGate 15.x and up.

These requirements also apply to Visual RPG for .NET Windows Deployment and the Upgrade Assistant.

Visual Studio VS 2015 1
Win 8.1 2
DataGate 14.x+ 3
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
1 - AVR 14.x requires VS 2015 Community Edition and up. This is the last year that the Community Edition works with AVR
2 - Microsoft retired Windows 8.1 in Jan 2023.
3 - AVR 14.x requires with DataGate 14.x and up.

WingsRPG


Mobile RPG


Monarch


Monarch Collector


Visual RPG Classic

These requirements also apply to Visual RPG Classic Deployment.

Win 8.1 1
DataGate 15.x+ 2
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
1 - Microsoft retired Windows 8.1 in Jan 2023.
2 - AVR Classic 5.1 requires DataGate 15.x and up.

These requirements also apply to Visual RPG Classic Deployment.

Win 8.1 1
DataGate 11.x+ 2
Win 10
Win 11
Win Srv 2012 R2
Win Srv 2016
Win Srv 2019
Win Srv 2022
1 - Microsoft retired Windows 8.1 in Jan 2023.
2 - AVR Classic 5.0 requires with DataGate 11.x and up.

ASNA Visual RPG 4.1 and 4.0 are retired and we do not recommend using them. If you're using one of these products we strongly recommend upgrading to AVR 5.1. If you have to use AVR 4.1/4.0, we recommend using DataGate 15.x or 16.x. Read more about ASNA Visual RPG 4.1/4.0.

These requirements also apply to Visual RPG Classic Deployment.

Win 7 1
Win 8.1 2
DataGate 15.x+ 3
Win 10
Win 11
Win Srv 2003 SP2
Win Srv 2008 R2
1 - Microsoft retired Windows 7 in Jan 2020.
2 - Microsoft retired Windows 8.1 in Jan 2023.
3 - AVR Classic 5.0 requires with DataGate 11.x and up.

These requirements also apply to Visual RPG Classic Deployment.

Win 7 1
Win 8.1 2
DataGate 15.x+ 3
Win 10
Win 11
Win Srv 2003 SP2
Win Srv 2008 R2
1 - Microsoft retired Windows 7 in Jan 2020.
2 - Microsoft retired Windows 8.1 in Jan 2023.
3 - AVR Classic 5.0 requires with DataGate 11.x and up.