Esta Política de Versión de Producto detalla los productos de ASNA actualmente disponibles y sus requisitos de plataforma.

Consulte esta página para obtener información sobre los productos descontinuados de ASNA.

ASNA Visual RPG para .NET

ASNA Visual RPG para .NET es un compilador de RPG para .NET. Sus versiones 16.x y 15.x están soportadas. Es compatible con las siguientes plataformas de desarrollo e implementación:

Product
Win 7
Win 8
Win 10
Win Srv 2008R2
Win Srv 2012R2
Win Srv 2016 and 2019
AVR 16.x
No
Yes
Yes
No
Yes
Yes
AVR 15.x
Yes
Yes
Yes
Yes
Yes
Yes

 

Cada versión de AVR para .NET requiere de su correspondiente versión de DataGate.

  • AVR para .NET 16.x requiere DataGate 16.x 
  • AVR para .NET 15.x requiere DataGate 15.x 
  • Lo mismo para versiones anteriores

Notas:

  • AVR 16.x requiere Visual Studio 2019.
  • AVR 15.x requiere Visual Studio 2017.
  • Todas las versiones comerciales de Windows son compatibles (es decir, Pro, Enterprise, Ultimate)....
  • Las versiones domésticas o móviles no son compatibles.
  • El soporte del sistema operativo de 64 bits es solo arquitectura X86-64. El procesador Itanium de 64 bits no es compatible.

ASNA Visual RPG Clásico

ASNA Visual RPG es un compilador RPG basado en COM.

Aunque las instalaciones y la implementación de AVR Clásico pueden estar disponibles en sistemas de 64 bits. las aplicaciones compiladas por AVR Clásico son siempre aplicaciones de 32 bits.

 
Plataformas de escritorio AVR Clásico para Windows y desarrollo web
Product
Win 7
Win 8
Win 10
AVR 5.1
Yes
Yes
Yes
AVR 5.0
Yes
Yes
Yes

 

AVR 4.1 y AVR 4.0 son ya productos descontinuados.


Notas:

  • Debido a importantes exposiciones de seguridad , Microsoft ha suspendido Windows XP. Recomendamos encarecidamente que actualice las aplicaciones de AVR Clásico 4.1 al menos a AVR Clásico 5.0 lo antes posible.
  • AVR Clásico 4.x no es compatible de ninguna manera con Windows 7, 8 o 10.
  • Las versiones domésticas o móviles de Windows no son compatibles.
  • El soporte del sistema operativo de 64 bits es solo arquitectura x86-64. El procesador Itanium 64 bit no es compatible.
 
Plataformas de despliegue de escritorio AVR Clásico:
Product
Win 7
Win 8
Win 10
AVR 5.1
Yes
Yes
Yes
AVR 5.0
Yes
Yes
Yes

 

Notas:

 
Plataformas de implementación de servidor AVR Clásico
Product
Win Srv 2008R2
Win Svr 2012R2
Win Srv 2016 and 2019
AVR 5.1
Yes
Yes
Yes
AVR 5.0
Yes
Yes
Yes

 

Notas:

 

ASNA DataGate para IBM i

Las versions 16.x y 15.x de DataGate para IBM i son compatibles.

Product
IBM i 7.1
IBM i 7.2
IBM i 7.3
IBM i 7.4
DataGate 16.x
No
Yes
Yes
Yes
DataGate 15.x
Yes
Yes
Yes
No

 

Notas:

 

ASNA DataGate para servidores y escritorios Windows

Se admiten las versiones 16.x y 15.x de DataGate Server para Windows.

Product
Win 7
Win 8
Win 10
Win Srv 2008R2
Win Srv 2012R2
Win Srv 2016 and 2019
DataGate 16.x
No
Yes
Yes
No
Yes
Yes
DataGate 15.x
Yes
Yes
Yes
Yes
Yes
Yes


Notas:

ASNA DataGate para servidor SQL

Las versiones 16.x y 15.x de DataGate para SQL Server son compatibles.

Product
Win 7
Win 8
Win 10
Win Srv 2008R2
Win Srv 2012R2
Win Srv 2016 and 2019
DataGate 16.x
No
Yes
Yes
No
Yes
Yes
DataGate 15.x
Yes
Yes
Yes
Yes
Yes
Yes


Notes:

ASNA Wings 10.0 

  • Monarch Collector - sigue los mismos requisitos de soporte que DataGate 16.0 para IBM i.
  • Wings Design Aid -sigue los mismos requisitos de soporte ASNA Visual RPG 16.x para Visual Studio 2019.

ASNA Wings 9.0 

  • Monarch Collector - sigue los mismos requisitos de soporte que DataGate 15.0 para IBM i.
  • Wings Design Aid - sigue los mismos requisitos de soporte ASNA Visual RPG 15.x para Visual Studio 2017.

ASNA Monarch 10.0 

  • Monarch Collector - sigue los mismos requisitos de soporte que DataGate 16.0 para IBM i.
  • Monarch Cocoon - sigue los mismos requisitos de soporte ASNA Visual RPG 16.x para Visual Studio 2019.

ASNA Monarch 9.0 

  • Monarch Collector - sigue los mismos requisitos de soporte que DataGate 15.0 para IBM i.
  • Monarch Cocoon - sigue los mismos requisitos de soporte ASNA Visual RPG 15.x para Visual Studio 2017.

ASNA Mobile RPG 10.0

  • Mobile RPG sigue los mismos requisitos de soporte que ASNA Visual RPG 16.0 para Visual Studio 2019.

ASNA Mobile RPG 9.0

  • Mobile RPG sigue los mismos requisitos de soporte que ASNA Visual RPG 15.0 para Visual Studio 2017.