This Product Version Policy details the currently available ASNA products and their platform requirements. 

ASNA Visual RPG for .NET

ASNA Visual RPG for .NET is an RPG compiler for .NET. Its versions 15.x and 14.x are formally supported. It supports the following development and deployment platforms:

Product
Win 7
Win 8
Win 10
Win Srv 2008R2
Win Srv 2012R2
Win Srv 2016
AVR 15.x
Yes
Yes
Yes
Yes
Yes
Yes
AVR 14.x
Yes
Yes
Yes
Yes
Yes
Yes


Notes:

  • AVR 15.x requires Visual Studio 2017
  • AVR 14.x requires Visual Studio 2015
  • All commercial versions of Windows are supported (ie, Pro, Enterprise, Ultimate)
  • Home or mobile versions of Windows are not supported
  • 64 bit operating system support is X86-64 architecture only. The Itanium 64 bit processor is not supported.

ASNA Visual RPG Classic

ASNA Visual RPG is a COM-based RPG compiler. It is available in two versions: 4.1 and 5.0. 4.1 is the original legacy product and is known to have substantial issues with most versions of Windows 7 and up. AVR 5.0 is a refreshed version of AVR 4.1 that supports Windows 7 and up, but doesn't support pre-Windows 7 platforms. AVR 4.1 and 5.0 are both formally supported.

Although AVR Classic installations and deployment may be available on 64-bit systems. the applications compiled by AVR Classic are always 32-bit applications.

 
AVR Classic desktop platforms for Windows and Web development
Product
Win XP SP3
Win 7
Win 8
Win 10
AVR 5.0
No
Yes
Yes
Yes
AVR 4.1
Yes
No
No
No
 
 
 


Notes:

  • Because of substantial security exposures, Windows XP has been discontinued by Microsoft. We highly recommend you upgrade AVR Classic 4.1 applications to at least AVR Classic 5.0  as soon as possible.
  • AVR Classic 4.x does not support Windows 7, 8, or 10 in any way.
  • Home or mobile versions of Windows are not supported
  • 64 bit operating system support is X86-64 architecture only. The Itanium 64 bit processor is not supported.
 
AVR Classic desktop deployment platforms:
Product
Win XP SP3
Win 7
Win 8
Win 10
AVR 5.0
No
Yes
Yes
Yes
AVR 4.1
Yes 
Yes 
No
No
 
 

 

Notes:

 

AVR Classic server deployment platforms
Product
Win Srv 2008R2
Win Svr 2012R2
Win Srv 2016
AVR 5.0
Yes
Yes
Yes
AVR 4.1
Yes
No
No

 

Notes:

ASNA DataGate for IBM i

DataGate for IBM i versions 15.x and 14.x are supported.

Product
IBM i 6.1
IBM i 7.1
IBM i 7.2
IBM i 7.3
DataGate 15.x
Yes
Yes
Yes
Yes
DataGate 14.x
Yes
Yes
Yes
Yes

 

Notes:

ASNA DataGate for Windows Servers and Desktops

DataGate for Windows and Servers versions 12.x and 14.x are supported.

Product
Win 7
Win 8
Win 10
Win Srv 2008R2
Win Srv 2012R2
Win Srv 2016
DataGate 15.x
Yes
Yes
Yes
Yes
Yes
Yes
DataGate 14.x
Yes
Yes
Yes
Yes
Yes
Yes


Notes:

  • Home or mobile versions of Windows are not supported

ASNA DataGate for SQL Server

DataGate for SQL Server versions 15.x and 14.x are supported.

Product
Win 7
Win 8
Win 10
Win Srv 2008R2
Win Srv 2012R2
Win Srv 2016
DataGate 15.x
Yes
Yes
Yes
Yes
Yes
Yes
DataGate 14.x
Yes
Yes
Yes
Yes
Yes
Yes


Notes:

  • Home or mobile versions of Windows are not supported

ASNA Wings 9.0 

  • Monarch Collector - follows the same support requirements for DataGate 15.0 for IBM i
  • Wings Design Aid - follows the same support requirementsfor ASNA Visual RPG 15.x for Visual Studio 2017

ASNA Wings 8.0 

  • Monarch Collector - follows the same support requirements for DataGate 14.0 for IBM i
  • Wings Design Aid - follows the same support requirementsfor ASNA Visual RPG 14.x for Visual Studio 2015

ASNA Monarch 9.0 

  • Monarch Collector - follows the same support requirements for DataGate 15.0 for IBM i
  • Monarch Cocoon - follows the same support requirementsfor ASNA Visual RPG 15.x for Visual Studio 2017

ASNA Monarch 8.0 

  • Monarch Collector - follows teh same support requirements for DataGate 14.0 for IBM i
  • Monarch Cocoon - follows the same support requirementsfor ASNA Visual RPG 14.x for Visual Studio 2015

ASNA Mobile RPG 9.0

  • Mobile RPG follows the same support requirements for ASNA Visual RPG 15.0 for Visual Studio 2017

ASNA Mobile RPG 8.0

  • Mobile RPG follows the same support requirements for ASNA Visual RPG 14.0 for Visual Studio 2015